BGP Protokolü Nedir? BGP protokolü Cisco konfigürasyonu

BGP Protokolü Nedir?

BGP (Border Gateway Protocol – Sınır Geçit Protokolü) internet sağlayıcıları tarafından kullanılan bir protokoldür.

Routerlara otonom sistem numarası atıyoruz. Otonom sistem numaraları 16 bit ile yani 1 ile 65535 arasında alınabiliyor. Autonomous system (AS) İngilizce kısaltmasıyla ifade ediliyor. 64512 ile 65535 arasın özel numaralardır (private range) yani herkes tarafından kullanılabilen numaralardır. Bgp hedefe giderken otonom sistem numarasını göz önüne alır, metrik hesaplar. BGP Distance Vector (Uzaklık Yönelim) algoritması kullanır.

Bir güncelleme (Update) paketi çıkarken otonom sistem numarası eklenir. Bu sayede döngü oluşması engellenir. Örneğin 100 AS numaralı bir routerdan çıkan güncelleme paketini kendi gönderdiğini biliyor ve gönderdiği güncelleme paketini kendisi almıyor. Bu sayede “loop” yani döngü engellenmiş olur.

BGP’nin kullandığı 3 tablo var;

  1. Neighbor tablosu
  2. BGP tablosu
  3. IP yönlendirme tablosu

BGP Özellikleri

  • BGP CIDR özelliğini destekler.
  • Her 60 saniyede bir periyodik olarak 19 byte uzunluğunda Keepalive mesajı gönderir ve bu sayede bağlantı açık kalır.
  • Güncelleme paketinde sadece değişen rotalar gönderildiği için gereksiz güncelleme paketi yollanmaz ve bu sayede gereksiz trafik engellenmiş olur.
  • BGP Bağlantı güvenliği için MD5 ile yetkilendirme sağlıyor.
  • İletişim için TCP 179. Portu kullanır.

BGP Konfigürasyonu

BGP komşulukları kendileri başlatmaz, biz bir komutla routerları birbirlerine komşu yapacağız. Neighbor komutu kullanılarak routerları birbirlerine komşu yapabiliyoruz. BGP’de  komşu routerlar PEER ( AKRAN )olarak adlandırılırlar.

Cisco Packet Tracer üzerinden BGP konfigürasyonu

2 farklı örnek yapacağız. İlk örneğimizde router-PC olacaktır. 2. Örneğimizde ise router-switch-PC olacaktır. 2 Örnek yapmamızın sebebi ikisi arasında pek bir fark olmayışıdır. Aslında sadece bir yerde farklılık olacak o da ilk örnekte direk PC lerin ip adresini yazacağız 2. Örneğimizde ise switch olduğu için PC lerin değil switch’in ip adresini yazacağız.

Router, PC BGP Konfigürasyonu

İlk örneğimiz bu olacak.

İlk olarak router bacaklarına ip adreslerini hızlı bir şekilde verelim.

  • Router(config)#interface fa0/0
  • Router(config-if)#ip address 192.168.1.1 255.255.255.0
  • Router(config-if)#no sh
  • Router(config-if)#exit
  • Router(config)#interface se2/0
  • Router(config-if)#ip address 192.168.2.2 255.255.255.0
  • Router(config-if)#no sh
  • Router(config-if)#clock rate 64000

Şimdi 2. Routerda da ip adresi verme işlemlerini tamamlayalım

  • Router(config)#int fa0/0
  • Router(config-if)#ip address 192.168.3.1 255.255.255.0
  • Router(config-if)#no sh
  • Router(config)#int se2/0
  • Router(config-if)#ip address 192.168.2.3 255.255.255.0
  • Router(config-if)#no sh
İP adresi verme işlemlerimiz bitti şimdi BGP Protokolü konfigürasyon işlemine geçiyoruz.

Tekrardan ilk router’a gelelim,

  • Router(config)#router bgp 100
  • Router(config-router)#network 192.168.1.0
  • Router(config-router)#network 192.168.2.0
  • Router(config-router)#neighbor 192.168.2.3 remote-as 200
  • Router(config-router)#neighbor 192.168.3.2 remote-as 200
  • Router(config-router)#do wr
  • Building configuration...
  • [OK]

Şimdi 2. Router’a gelelim,

  • Router(config)#router bgp 200
  • Router(config-router)#network 192.168.2.0
  • Router(config-router)#network 192.168.3.0
  • Router(config-router)#neighbor 192.168.1.2 remote-as 100
  • Router(config-router)#neighbor 192.168.2.2 remote-as 100
  • Router(config-router)#%BGP-5-ADJCHANGE: neighbor 192.168.2.2 Up
  • Router(config-router)#do wr
  • Building configuration...                      
  • [OK]

Ve komşuluğu sağlamış olduk. Şimdi PC lere gelip Neighbor komutuyla belirtmiş olduğumuz ip adreslerini veriyoruz. AS 100 olan taraftaki PC ye 192.168.1.2 diğer PC ye 192.168.3.2 ip adresini verip ping atabiliriz.

Şimdi 2. Örneğimize Geçiyoruz

Router, Switch, PC BGP Protokolü Konfigürasyonu

2. BGP Protokolü örneğimize başlayalım yine ilk olarak ip adreslerini verelim.

  • Router(config)#int fa0/0
  • Router(config-if)#ip address 192.168.10.1 255.255.255.0
  • Router(config-if)#no sh
  • Router(config-if)#exit
  • Router(config)#int se2/0
  • Router(config-if)#ip address 192.168.20.2 255.255.255.0
  • Router(config-if)#no sh

2. router

  • Router(config)#int fa0/0
  • Router(config-if)#ip address 192.168.30.1 255.255.255.0
  • Router(config-if)#no sh
  • Router(config-if)#exit
  • Router(config)#int se 2/0
  • Router(config-if)#ip address 192.168.20.3 255.255.255.0
  • Router(config-if)#no sh

Şimdi BGP konfigürasyonunu yapalım ilk routera geliyoruz

  • Router(config)#router bgp 100
  • Router(config-router)#network 192.168.10.0
  • Router(config-router)#network 192.168.20.0
  • Router(config-router)#neighbor 192.168.30.1 remote-as 200
  • Router(config-router)#neighbor 192.168.20.3 remote-as 200

2. router

  • Router(config)#router bgp 200
  • Router(config-router)#network 192.168.30.0
  • Router(config-router)#network 192.168.20.0
  • Router(config-router)#neighbor 192.168.10.1 remote-as 100
  • Router(config-router)#neighbor 192.168.20.2 remote-as 100
  • Router(config-router)#%BGP-5-ADJCHANGE: neighbor 192.168.20.2 Up

Komşuluğu kurmuş olduk. PC lere ip adresi vererek ping atabiliriz.

Bu yazımızda BGP protokolünün Ne olduğunu, konfigürasyonunun nasıl yapılacağı gibi bilgileri anlatmaya çalıştım. Umarım Yararlı olmuştur. Başka yazılarda görüşmek üzere İyi Günler Dilerim…

Diğer yazılarımıza ulaşmak için https://bilgikupu.net/ sitemizi ziyaret edebilirsiniz.

İbrahim Salih DEMİRAL

Herkese Merhaba! Ben OMÜ Bilişim Güvenliği Teknolojisi öğrencisiyim. Bu bloğumuz da sizlere kendi yorumlarımı da katarak belirli konularda bilgi vermeye çalışacağım. Bazı uygulamaların kullanımını ve kurulumlarını yazacağım. Kurulumları yazılı ve video gönderisi olarak sizlere sunacağım. Şimdiden Teşekkürler...

You may also like...

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir